IBM Support

Order Hub throws 'OMS instance was unreachable'

Troubleshooting


Problem

On logging in to the Order Hub application, users are unable to access the Order Hub UI. The landing page displays the error message '(OMS instance was unreachable. https://abc.ibm.com/smcfs/)'.

Cause

This error can be caused due to several reasons, although below are the most common causes:
  1. Sterling Order Management (OMS) System is down due to an outage or planned deployment.
  2. On reviewing the network/har logs (generating a HAR file.), within the getPage call, “YFS10363: getResourcesForUser Element must be passed” error is seen.

Resolving The Problem

  1. Sterling Order Management (OMS) System is down due to an outage or planned deployment.
    • Log into one of the OMS applications like Sterling Business Center (SBC) or IBM Call Center for Commerce and validate that you are able to access the application without any issues.
    • If you are seeing any issues, validate that there are no planned outages, maintenances, or scheduled deployments ongoing.
  2. Error is being thrown from the networking logs pointing to some getResourcesForUsers issue.
    • Extract the xml template\resource\restApiMetadata.xml from your resources.jar in your EAR (or from <runtime>\jar\platform\10_0\resources.jar). Validate if the below entry is present.
<Api Name="getResourcesForUser">
  <Input PK="UserKey" TagName="getResourcesForUser"/>
</Api>
  • If not, add the above entry and redeploy the extension jar.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS6PEW","label":"IBM Sterling Order Management"},"ARM Category":[{"code":"a8m0z000000cy05AAA","label":"OrderHub"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"SaaS"}]

Document Information

Modified date:
30 June 2023

UID

ibm16981617