IBM Support

Opening the DOORS module tools menu and the module properties context menu are taking a long time to load for the first time

Troubleshooting


Problem

Opening the DOORS module tools menu and the module properties context menu are taking a long time (>5 minutes) to load for the first time.

Symptom

 After the first load attempt completes, subsequent load attempts will behave normally (appear instantly).

Cause

You already have performance issue loading the project view.
This delay issue can be happen in a large database, such as a database that has over 2000 projects and is accessed over a slow connection (average latency > 30ms, maximum latency > 50ms) (such as VPN or WAN connections).
A module is located inside a second or lower level project.
For example: 
/Folder1/Folder2/project1/project2/Folder3/project3/module
The 'fullname' property of the module would be
/project3/module
The DOORS client logic, that is checking for the existence of this module through the module's fullname property, "/project3/module",  has to load the entire project index, which can contribute to slowness and the symptoms of slow menu open response times on first try. The index remains cached for the remainder of the session, so subsequent access to menus is faster. 

Environment

Windows, DOORS client, slow network connection to DOORS server, DOORS database with modules inside projects at second or lower levels.

Diagnosing The Problem

Check the DOORS version - 9.7.x
Number of projects in database - where a large number of projects exists, including projects at second level and lower levels.
Performance issue loading the project list view - indicative of project index being loaded
Module in first level project should not expose the increased tools and properties menus load times.
Only happens to module in second level or lower.

Resolving The Problem

This is a project defect/Known Issue (DT269358)
Please contact IBM DOORS product support to discuss access to a corresponding testfix, which can be applied until defect DT269358 has been fixed in an official fixpack or release.

Document Location

Worldwide

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Document Information

Modified date:
19 March 2024

UID

ibm17138769