Troubleshooting
Problem
WebSphere Adapter for JDBC receives NumberFormatException when entering a number greater than 1,000 for the resultsets for a stored procedure.
Symptom
The trace from WebSphere Adapter for JDBC prints out the following information in runtime :
java.lang.NumberFormatException:
Ý16/10/09 19:40:00:354 BRT¨ 0000012a ExceptionUtil E CNTR0020E: EJB threw an unexpected (non-declared) exception during invocation of method "transactionNotSupportedActivitySessionNotSupported" on bean "BeanId(SIGHA_GUIASApp#SIGHA_GUIASEJB.jar#Module, null)". Exception data: com.ibm.websphere.sca.ServiceRuntimeException: ResourceException thrown in J2CMethodBindingImpl.invoke() javax.resource.ResourceException: java.lang.NumberFormatException: For input string: "1,000"
at com.ibm.ws.sca.internal.j2c.J2CMethodBindingImpl.invoke(J2CMethodBindingImpl.java:476)
For a normal scenario, this value should be less than 999. For this scenario, however the value is set to 9999 and it causes an issue:
Cause
"MaxNumOfRetRS" is internally handled as a numeric value. Thus, when the input value is greater than 999, NumberFormatException occurs in runtime.
Resolving The Problem
Follow the following workarounds:
If you are using Oracle "MaxNumOfRetRS" is meaningless. In this case, a simple workaround is to leave the input value for "MaxNumOfRetRS" as default (0).
For other databases, "MaxNumOfRetRS" needs to be set to the result set number returned by the database.
Or :
Contact IBM support for the IBM WebSphere Adapter for JDBC, version 6.2.0.3_IF02.
Was this topic helpful?
Document Information
Modified date:
23 June 2018
UID
swg21408744