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Number of records from YFS_HEARTBEAT for active servers changes frequently when running HealthMonitor agent

Question & Answer


Question

Why does the number of records from YFS_HEARTBEAT vary while HealthMonitor agent is run? Query used to determine the number of active application servers - select count(*) from yfs_heartbeat where SERVER_TYPE='APPSERVER' and status='00';

Cause

The behavior is caused due to yfs.yantra.statistics.persist.interval being configured to use a value greater than yfs.heartbeat.refresh.interval.

Answer

Check the value of yfs.yantra.statistics.persist.interval and yfs.heartbeat.refresh.interval in yfs.properties and customer_overrides.properties.

yantra.statistics.persist.interval - Property to determine statistics logging time interval. Format of the property is Xm or Xh where X is an integer between 1 and 60 and M/m for minutes or H/h for hours.

yfs.heartbeat.refresh.interval - Property to determine heartbeat refresh time interval. Format of the property is Xm or Xh where X is an integer between 1 and 60 and M/m for minutes or H/h for hours

The Healthmonitor agent consider a JVM stale based on yfs.heartbeat.refresh.interval. But the heartbeat syncronization is made based on the value of yfs.yantra.statistics.persist.interval.

IBM® recommends that the value of property, yfs.heartbeat.refresh.interval, should be set greater than the value of the yantra.statistics.persist.interval property.

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Document Information

Modified date:
16 June 2018

UID

swg21973149