IBM Support

"Not authorized" when logon to Controller Web, caused by missing TLS encryption options in "jvm.options" configuration file

Troubleshooting


Problem

User launches Controller Web. User chooses database, and types in username/password.
An error appears.

Symptom

image 2675
Not authorized

Cause

There are many different possible causes for this generic message.
  • See separate IBM Technote #1288582 for more examples.
This Technote specifically relates to the scenario where the cause is that both of the following are true:
  • The database server has been configured to reject all communication unless it is TLS 1.2
  • Controller Web is not configured to use TLS 1.2, because of missing encryption/TLS/SSL configuration options in the file:  jvm.options 

Environment

This Technote only relates to specialised environments, where the database server has been configured to reject all communication unless it is TLS 1.2. 

Resolving The Problem

Force Controller to connect to the database using TLS 1.2, by adding some parameters to the configuration file:  jvm.options 
  
Steps:
1. Browse to the folder:    ...\ccr_64\fcmweb\wlp\etc\
  • TIP:  By default this is located here:    C:\Program Files\ibm\cognos\ccr_64\fcmweb\wlp\etc\
2. Open the following file in NOTEPAD:   jvm.options
3. Add the following lines (at the end):
-Dcom.ibm.jsse2.overrideDefaultTLS=true
-Dcom.ibm.jsse2.overrideDefaultProtocol=TLSv12
4. Save changes
5. Restart the Windows service:    IBM Cognos Controller Web

Document Location

Worldwide

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Document Information

Modified date:
25 March 2020

UID

ibm16117838