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Not able to create return orders for imported order in IBM Sterling Order Management System

Troubleshooting


Problem

Attempts to create a return for an order which is imported from external system throws the error YFS: Not Enough Quantity.

Symptom

Steps to reproduce:

  1. Import an order which is in Shipped status using importOrder API.


  2. Import corresponding shipment for the above order using importShipment API


  3. Search for this order from application console. It should show order details along with shipment information.


  4. Search for this sales order from Call Center for Commerce application.
    Click on 'Where is my Shipment'.

    Result : System displays a message 'Shipment information is not available because this product was shipped using a vendor. '


  5. Click on Create Return.
    Result : System displays a message -'There is no quantity available for return on this product line.'

  6. Try creating return Order from API tester
    Result : Below error is thrown -
     ErrorCode="YFS10131" ErrorDescription="YFS: Not Enough Quantity"

Cause

Data migration

Diagnosing The Problem

From log analysis it is inferred that the SO doesn't have any quantity in status 3700(Shipped), due to which there's no mapped qty to return while creating return order from call center. Further review of input xmls in conjunction with API docs shows that in sales order import xml, Status is being passed as "Shipped". Since, this 'Status' attribute is actually mapped to the status column of YFS_ORDER_RELEASE_STATUS table which contains status codes and not description, the problem is with the importOrder input xml.

Resolving The Problem

To resolve, change the importOrder input xml and pass Status="3700" instead of Status="Shipped". Below is the input xml for reference -

<Order DocumentType="0001" EnterpriseCode="DEFAULT" OrderNo="TEST_ORDER001" PaymentRuleId="DEFAULT" SellerOrganizationCode="DEFAULT" >
 <PersonInfoBillTo Country="US" />
 <OrderLines>
      <OrderLine PipelineOwnerKey="DEFAULT" PipelineId="SALES-9.5" DeliveryMethod="SHP" OrderedQty="1" OriginalOrderedQty="1" PrimeLineNo="1" ReturnReason="" SubLineNo="1">
          <Item ItemDesc="ITEM" ItemID="ITEM" ItemShortDesc="ITEM" UnitOfMeasure="EACH"/>
   <OrderStatuses>
           <OrderStatus Status="3700" StatusQty="1">
                   <Schedule ShipNode="NODE" ExpectedDeliveryDate="2017-08-01T09:15:29-04:00" ExpectedShipmentDate="2017-08-01T09:15:29-04:00"/>
    </OrderStatus>
          </OrderStatuses>
  </OrderLine>
 </OrderLines>
</Order>

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Sterling Call Center","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"9.5","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg22006743