IBM Support

Nodes cannot download kickstart file

Troubleshooting


Problem

Provisioning of nodes may fail sometimes because the nodes cannot download the kickstart file from the installer node. This article describes common causes of this error and steps to troubleshoot.

Symptom

Compute nodes fail to provision, and the following error message appears on the node's console:

 

"Unable to download the kickstart file. Please modify the kickstart parameter below or press Cancel to proceed as an interactive installation"

See attached image.

Cause

There are several reasons why this message can appear. The common reasons are:

  • Network profile is mis-configured
  • Image profile does not include network card drivers

Environment

This issue was reproduced on PCM 4.1 SE on RHEL 6.3

Resolving The Problem

Issue caused by mis-configured network profile

Typically, this happens when the image profile is configured for one network interface (i.e eth0) while the compute node is configured to PXE boot from another interface (i.e. eth1).

To fix the issue, you must edit the network profile used by this compute node and change the network interface to match the physical interface node boots from. To do this, follow these steps:

 

  1. Go to RESOURCES >> Node Provisioning >> Provision Templates >> Network Profiles page
  2. Select the profile you are using to provision the compute nodes (i.e. default_network_profile) and select Modify
  3. Select Yes if prompted that the profile is already in use
  4. Select Add to add a new primary interface
  5. Input following information: Interface Name = eth1: Type=Ethernet: Network= provision
  6. Change the Primary Interface to match the physical interface nodes PXE boot from (i.e. change eth0 to eth1)
  7. Select Ok to close the Modify window of the network profile

 

 

After you fix the network profile, you must remove the node which failed to install, and then re-add it again. The node will now be able to complete provisioning because the configured provision interface is the same and the physical interface used to PXE boot the node.

Issue caused by missing kernel modules from image profile

 

If you are trying to provision stateless nodes, it is possible that the image profile you are using does not have kernel modules that support network hardware in the nodes

To fix this, you must add the appropriate kernel drivers to the image profile used by your compute nodes.

  1. Determine what network hardware is used by your compute nodes, and which drivers are required to support it. This step is very important - you cannot proceed without this information.
  2. Go to RESOURCES >> Node Provisioning >> Provision Templates >> Image Profiles
  3. Select the image profile you are using to provision the compute nodes (i.e. rhels6.3-x86_64-stateless-compute) and select Modify
  4. Select Yes if prompted that the profile is already in use
  5. Select the Kernel Modules tab
  6. In the list of modules, select the module identified in step 1 and click Ok
  7. In the Confirmation window, review the changes and select Ok
  8. After the image is re-built select Close .

 

After you fix the image profile you must reinstall the nodes. The node will now be able to complete provisioning because it will have the necessary drivers for its network hardware.

 

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Document Information

Modified date:
16 September 2018

UID

isg3T1019403