IBM Support

SystemServerConnectWithCAMNamespace takes more and more time and may end with request timeout error

Troubleshooting


Problem

TM1 Server is configured with CAM security ( IntegratedSecurityMode=5 )
A lot of TI processes are executed through TM1RunTI tool within a scheduled batch.
This generates a lot of connection requests onto Cognos Analytics Content Manager.
TM1Top shows that SystemServerConnectWithCAMNamespace operation is taking more and more time ; connecting to the CAM namespace can then take from few seconds to several minutes.

Cause

By default, in Content Manager, multiple sessions from a single user are queued.
All executions of TM1RunTI are done as the same TM1 admin user (which is mapped to the same corresponding CAM user) : this causes a bottleneck in Content Manager.

Resolving The Problem

The advanced setting SessionSharing=False is allowing users to launch multiple exports/reports/jobs using the same user.
By default, multiple sessions from a single user are queued.
With SessionSharing=False, multiple sessions from a single user will be processed in parallel.
Here are the steps (CM server):
1. Stop the "Cognos" service in your environment.
2. In your Cognos Configuration (in Content Manager), click on your AD namespace to bring up the settings on the right.
3. Under "Advanced Settings", click on the pencil icon to bring up the settings window
4. Click the "Add" button to add the following parameter and value:
Parameter: SessionSharing Value: False
5. Once the value has been added, save the changes in your Cognos Configuration and start the service.

Document Location

Worldwide

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Document Information

Modified date:
19 August 2019

UID

ibm10996886