IBM Support

Registry update failures running rich client in the toolkit

Question & Answer


Question

If you attempt to run a HATS rich client project in debug mode, and you are not an Administrative user, you might see error messages in your console if you have the display terminal enabled.

Cause

If you attempt to run a HATS 7.0 rich client project in debug mode, and you are not an Administrative user, you might get the following error messages in your console if you have the display terminal enabled:

Feb 20, 2008 11:22:26 AM java.util.prefs.WindowsPreferences <init>
WARNING: Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows
RegCreateKeyEx(...) returned error code 5.
Feb 20, 2008 11:22:26 AM java.util.prefs.WindowsPreferences WindowsRegOpenKey1
WARNING: Trying to recreate Windows registry node Software\JavaSoft\Prefs at root 0x80000002.
Feb 20, 2008 11:22:26 AM java.util.prefs.WindowsPreferences openKey
WARNING: Could not open windows registry node Software\JavaSoft\Prefs at root 0x80000002. Windows RegOpenKey(...)
returned error code 2.

When the rich client connection starts, there is an attempt to open the host terminal. When starting the host terminal, the following registry key is needed:

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Prefs

The error messages occur because the registry key is missing, and HATS attempts to create
the key without having Administrator privileges.

Answer

The project and display terminal function correctly despite the error messages. There are two solutions to prevent the error messages from appearing in the console in the future. Only one of the following solutions is necessary:

  • Run the HATS Toolkit as a Administrative user. Starting the toolkit by right clicking the icon and selecting Run as.... In the Run As dialog, select a user that has Administrative authority. Run the rich client project in debug mode, with the host terminal turned on. Since the HATS Toolkit has Administrator privileges, the registry key is created.
  • Have an Administrative user manually create the registry key, using the following process:
    1. Click Start > Run... Type regedit in the Run dialog box.
    2. Locate the following registry key: HKEY_LOCAL_MACHINE > SOFTWARE
    3. Right click the key and select New > Key. Name the new key JavaSoft.
    4. Right click the new JavaSoft folder and select New > Key. Name the new key Prefs.
    5. The Prefs folder appears under the JavaSoft folder under the HKEY_LOCAL_MACHINE > SOFTWARE registry key.
    When the key is created, the error messages no longer appear in the console when starting
    the debug host terminal.

[{"Product":{"code":"SSXKAY-2","label":"Rational Host Access Transformation Services"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF012","label":"IBM i"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF035","label":"z\/OS"}],"Version":"7.0","Edition":"","Line of Business":{"code":"LOB35","label":"Mainframe SW"}},{"Product":{"code":"SSXKAY","label":"IBM Host Access Transformation Services"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":null,"Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB35","label":"Mainframe SW"}}]

Document Information

Modified date:
26 August 2022

UID

swg21299021