IBM Support

Cognos Analyticsの「レガシー・カスタム・フィルター」ダイアログを使用可能にする方法

Troubleshooting


Problem

Cognos Analyticsが予期したとおりに機能していません。 
Cognos Analytics 11の新しいレポート編集画面の「カスタム・フィルターの作成」ダイアログが変更されました。
Cognos 10で拡張フィルター条件を定義するために利用していた特定の機能が使用できません。
例えば、ユーザーはフィルター条件の設定で、前方一致、後方一致、部分一致、パターンマッチングなどを利用することができません。

Cause

Cognos Analyticsは、一時的に、カスタム・フィルターを簡素化したUIとなっています。

Resolving The Problem

現在の簡素化されたフィルター・ダイアログでは、拡張フィルター機能はサポートされていません。 これは、将来のリリースで対応される予定ですが、現時点では未対応で、製品の制約となっています。
拡張フィルター機能を使用する必要があるお客様については、以下の回避策を使用して、レガシー・フィルター・ダイアログを使用可能にしてください。 これは、新しい拡張フィルター機能がリリースされるまでの一時的な回避策です。
レガシー・フィルター・ダイアログを使用可能にする手順は次のとおりです。
(1) 各サーバーで、webcontent/bi/patの下のDefaultSettings.xmlを見つけます。(これはwebcontent/patにはありません)
(2) DefaultSettings.xmlをエディターで開き、
<setting name="UseOldCustomFilterDialog" defaultValue="false" dataType="boolean" propType="debug" label="Use Old Filter Dialog"/>
を、
<setting name="UseOldCustomFilterDialog" defaultValue="true" dataType="boolean" propType="debug" label="Use Old Filter Dialog"/>
に変更しファイルを保存します。
(3) Cognosサーバーを再始動します。
これにより、カスタム・フィルターがCognos10のデザインに戻ります。

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"Administration and Configuration v11x","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"Cognos Analytics11.0.10","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Historical Number

2016757

Document Information

Modified date:
18 November 2019

UID

ibm10957701