IBM Support

Intermittent "Unable to fetch data" errors when opening views (inside Books) in PAW, caused by APAR PH07697

Troubleshooting


Problem

User launches PAW, opens a book and tries to view reports. An error appears.
The problem may be intermittent.

Symptom

Errors similar to:
  • Unable to fetch data
  • Unable to drill.
  • Unable to modify the view hierarchy.
  • Unable to fetch data. Unable to compose your request.
  • Unable to apply your selection.
  • Unable to retrieve server capabilities for prime.

Cause

Defect (reference APAR PH07697) in PAW.
More Information:
The defect is triggered by a proxy time limit of 2 minutes for any process.
  • For example, the user may hit this limit when opening a view (in a report).
The issue may occur intermittently because during the time when the first user is trying to open a report (cube view), in the background there could be other long-running query(ies). These could cause the first user's process to go into a locked state.
  • That first user would need to wait for the other queries to complete (before theirs is able to run)
  • If this waiting akes more than 2 minutes, then the first user's request will reach the timeout of 2 minutes (and therefore fail).

Diagnosing The Problem

Launch PAA (PA administration) component and look at the running threads.
  • If the process takes over to 2 minutes to complete, then the issue will occur.

Resolving The Problem

Fix:
Await future version of PAW, which will include a fix for this defect.
  • TIP: To be automatically notified when this version is available, subscribe to APAR PH07697.
Workarounds:
Method #1
In many cases, the user is able to simply:
1. Close the error
2. Re-try (successfully this time).
Method #2
Review the model itself and see if any changes to the model (views) can be done to better the performance (to make sure it always runs under the 2minute timeout).

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSD29G","label":"IBM Planning Analytics"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
20 September 2021

UID

ibm10957105