IBM Support

Planning Analytics for Excel: System.ObjectDisposedException: Cannot access a disposed object

Troubleshooting


Problem

Users are receiving this error message while connecting or while working in Planning Analytics for Excel:
System.ObjectDisposedException: Cannot access a disposed object.
Object name: 'Tm1AuthBrowser'.
at
System.Windows.Forms.Control.CreateHandle()
at System.Windows.Forms.Form.CreateHandle()
at System.Windows.Forms.Control.get_Handle()
at System.Windows.Forms.Form.ShowDialog(IWin32Window owner)
at Cognos.Office.Framework.SingleDialog.ShowDialog(Form form, IWin32Window owner)
at Cognos.Office.Tm1.Security.UILogon.BrowserLogon(String title, String connectURL, String serverPath, CookieCollection cookies, Boolean largeLogonDialog)
at Cognos.Office.Tm1.Tm1DataSource.HostLogon(Tm1AuthenticationProperties properties)
at Cognos.Office.Tm1.Tm1DataSource.Logon(LogonType logonType, DataSourcePropertiesCollection properties)
at Cognos.Office.Framework.Communications.DataSourceManager.LogOn(String dsType, String connectionString, String serverName, IDataSource& source)

Cause

Either Planning Analytics Application Server ("IBM Cognos TM1" service) is unresponsive, or some Workspace containers are not working anymore, or communication is broken between Workspace and Planning Analytics Application Server for unknown reason.

Environment

Windows Server 2016

Resolving The Problem

1)  From the Planning Analytics for Excel client machine, open Internet Explorer and verify that PA Application server is responding, by connecting to TM1 Web :
http://YourTM1WebServer:9510/tm1web
Then try to connect to your TM1 Server from here.
2) From the Planning Analytics for Excel client machine, open Internet Explorer and verify that Workspace is responding :
http://Your Workspace machine<:port_if_not_default_80>
3) If 1 and 2 are OK, then try to restart PA Application Server ("IBM Cognos TM1" service)
4) If still not sufficient, try to stop Workspace and restart Docker (which will restart containers automatically):
Open a Powershell on the Workspace server machine
cd <Workspace_install_path>
./scripts/paw.ps1 ps 
(the above command will show the state of each container : in a normal situation everything should be "Up" except the "bss-init" container. Executing this command may give us some clues about what the issue is : if some containers are in "Exit" status then share this with IBM Support and send a zip of the <Workspace>/log folder)
./scripts/paw.ps1 stop
(the above command will properly stop all containers)
restart-service docker*
(the above command will restart "docker" or "docker engine" service ; the name depends on the docker version that has been installed)
After some time, run this command again to verify that all containers are "Up" except "bss-init" :
./scripts/paw.ps1 ps 
If this is still not working after these steps then contact IBM Support

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSCTEW","label":"IBM Planning Analytics Local"},"Component":"Planning Analytics for Excel","Platform":[{"code":"PF033","label":"Windows"}],"Version":"2.0.42","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
18 October 2019

UID

ibm10956453