IBM Support

Dispatchers Can't Connect To Failover Content Manager When Primary Content Manager Is Turned Off

Troubleshooting


Problem

When the primary CM is started first, all other dispatchers and CM are able to start and work properly.
When the failover CM is started first, the dispatchers are not able to connect to the CM.
Error Received:  "CAM-CRP-1315 Current configuration points to a different Trust Domain than originally configured".

Symptom

The error suggests an issue with the cryptographic keys, however, regenerating the keys doesn't resolve the issue.

Cause

"Use third party CA" was set in the configuration.  
Since the internal URIs are not using HTTPS, this setting is not required and actually caused issues with the auto certs generated.  
With this setting turned off (default) and a regeneration of the crypto keys,  the dispatcher save worked without issue when the primary CM was turned off.

Environment

Distributed installation with two Content Managers, three dispatchers, and a gateway, all on Windows servers.
For the purpose of troubleshooting, turned off everything except for the two CMs and one dispatcher.

Diagnosing The Problem

Confirm that the same Content Store database is configured for both CMs, and using the same Content Store logon.
Switching the order of the CM URIs doesn't resolve the issue.

Resolving The Problem

Switch "Use third party CA" to false in Cognos Configuration if internal URIs are not HTTPS and regenerate the cryptographic keys.

Document Location

Worldwide

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Document Information

Modified date:
19 June 2019

UID

ibm10888155