IBM Support

Planning Analytics Workspace not starting on Windows Server 2016 - ActivateLayer failed in Win32

Troubleshooting


Problem

You have installed Planning Analytics Workspace on Windows Server 2016. 

When starting the application, you face the following error for one or more containers:
ActivateLayer failed in Win32: The process cannot access the file because it is being used by another process.

Cause

These type of errors typically occur due to interference of AntiVirus software on the Windows Server.

Resolving The Problem

  • To resolve this problem, you should work with your AntiVirus vendor to determine if the version of AntiVirus you are using is supported for use with Docker/Containers.
  • Should the AntiVirus vendor claim that it does support Docker/Containers, we request that the AntiVirus software still be temporarily disabled on the Planning Analytics Workspace server to completely rule out the AntiVirus software.  Although a vendor may claim that the AntiVirus software does support Docker/Containers, there may still be a problem that requires further investigation
Please also note that AntiVirus software may not be the only software that can cause a problem such as this.  Any type of tools you have enabled for Operating System / File Monitoring could potentially cause such a problem and may require additional investigation.

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSCTEW","label":"IBM Planning Analytics Local"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
12 June 2019

UID

ibm10887561