IBM Support

Scheduled Database Optimization Fails with message "Database optimization completed with error" / "Remote server URL not defined!"

Troubleshooting


Problem

After setting up a scheduled database optimization, it seems to fail with no error details in the Batch Queue job detail.
However, manual database optimization works properly.

Symptom

Screen:
When scheduling a database optimization, it fails without giving any error in the batch queue list:
scheduled optimization error
Database optimization completed with error
Finished with Error Database Optimized
  
Event Viewer
In event viewer (on the Controller Application / Batch Server), the following error can be seen:
Description:
Error occured: System.Exception: Remote server URL not defined!
   at CCRRemoteServerProxy.RemoteServerProxy.InitProxy(ControllerSoapHttpClientProtocol& prx, String wssUrl)
   at CCRRemoteServerProxy.RemoteServerProxy.get_g_proxySessionManagerClient(String passport, String wssUrl)
   at ControllerServerCommon.SessionManagerClient..ctor(String guid, String userId, String database, Int32 applicationId, String wssUrl)
   at FrDatabaseBT.OptimizeT.RunOptimization(String sGuid, String sUser, String& Spara, Int32 lJobID, Int32 lSchedDate, Int32 lSchedTime, String& sLogErrText, Boolean bBatch, String wssUrl)

Cause

Limitation of Controller 10.4.0 (and later), where an incorrect value (for the WSSUrl tag.) is created inside the config file:  CCRBatch.exe.config

Environment

Controller 10.4.0

Diagnosing The Problem

Open Controller and schedule a database optimization. Notice that it had failed without providing any useful error in the Batch Queue list, but with an error in Event Viewer (on the Controller Application Server) similar to the one mentioned in the 'Symptom' section.

Resolving The Problem

Fix:
Edit the value for "WSSUrl" inside the config file:  CCRBatch.exe.config
Steps:
1. Logon to the Controller Application Server:
2. Browse to the 'server' folder
  • TIP: By default, this is here: c:\Program Files\ibm\cognos\ccr_64\server\
3. As a precaution, create a backup copy of: CCRBatch.exe.config
4. Open the following file (for example in Notepad):  CCRBatch.exe.config
5. Scroll down to the end of the file, and locate the section/tag:   </appSettings>
6. Locate the entry similar to:
  <add key="WSSUrl" value="http://localhost:1969" />
7. Modify the entry to the correct value:
 <add key="WSSUrl" value="http://localhost/ibmcognos/controllerserver" />
Batch config
8. Save changes
9. Restart the Windows service "IBM Cognos Controller Batch Service"
10. Test.
   
Workaround:
Perform an unscheduled (manual) database optimisation.

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.4.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
04 June 2019

UID

ibm10886589