Troubleshooting
Problem
Using the Search feature in Cognos 11.0.13 FP1 does not work as one might expect. It probably find the exact object but on top many others. On the other side it might not find the object but some others that are just similar.
Symptom
Search for an object with a specific name does not find it or find many other similar objects but not the one that is expected.
Cause
The search result match mechanism has been improved in FP1 but to enable it some steps are necessary.
Environment
Cognos 11.0.13 FP1
Cognos 11.1.* is NOT affected since that setting is enabled by default
Resolving The Problem
Configuration flag called "SearchService.enableExactMatching" must be set to true, and server restart/index rebuilt for feature to work. To enable the flag:
Using ConfigSetter:
1. Start CA system
2. Logon to Cognos via the Dispatcher URL http://<host>:<port>/bi/
3. Open a new tab in same browser session and navigate to http://<host>:<port>/bi/ConfigSetter.html
4. Under Name enter "SearchService.enableExactMatching" (or better copy this into the field)
5. Now press "Tab" key and it hop to the Value: field and will show "false" automatically
6. If this is the case then change false to true and click "Submit"
7. You will get a popup that confirm the configuration has been updated
8. Stop Cognos, rename the index (..\data\search\indices\cm to XYcmXY and mo to XYmoXY). This rename step is just for backup purposes. You might delete it later.
9. Start Cognos, it will create the index anew and the search should work with a better exact match result
2. Logon to Cognos via the Dispatcher URL http://<host>:<port>/bi/
3. Open a new tab in same browser session and navigate to http://<host>:<port>/bi/ConfigSetter.html
4. Under Name enter "SearchService.enableExactMatching" (or better copy this into the field)
5. Now press "Tab" key and it hop to the Value: field and will show "false" automatically
6. If this is the case then change false to true and click "Submit"
7. You will get a popup that confirm the configuration has been updated
8. Stop Cognos, rename the index (..\data\search\indices\cm to XYcmXY and mo to XYmoXY). This rename step is just for backup purposes. You might delete it later.
9. Start Cognos, it will create the index anew and the search should work with a better exact match result
Document Location
Worldwide
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"Search","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.0.13 FP1+","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
04 June 2019
UID
ibm10886581