Troubleshooting
Problem
I.T. administrator launches the Cognos Analytics (CA) program 'Cognos Configuration'. Administrator clicks 'start' icon. The service begins its routine to start the service.
However, very little information appears on the screen. After a long time (approximately 15 minutes) an error appears.
Symptom
[Start Service]
[ ERROR ] CFG-ERR-0106 IBM Cognos Configuration did not receive a response from the IBM Cognos service in the time allotted.
Check that IBM Cognos service is available and properly configured.
[ ERROR ] CFG-ERR-0106 IBM Cognos Configuration did not receive a response from the IBM Cognos service in the time allotted.
Check that IBM Cognos service is available and properly configured.
Cause
There are many possible causes for similar 'CFG-ERR-0106' errors.
- TIP: See separate IBM Technote #1646350 for more examples.
This Technote specifically relates to the scenario where the cause is corruption inside 'workarea' folder of Cognos Analytics.
Environment
In one real-life customer example:
- Everything was working OK for many months
- The problem occurred suddenly one day.
Diagnosing The Problem
(1) There is no update inside the 'cogserver.log'.
- TIP: This is located inside: <install_location>\analytics\logs
In fact, if the user deletes the file 'cogserver.log' and then restarts the service, then a new 'cogserver.log' file does not get created!
(2) If the 'IBM Cognos' service runs under a specific Windows user, then (looking in Task Manager), the only processes running (under that account) are:
- cogbootstrapservice.exe
- conhost.exe
- java.exe
Resolving The Problem
Reset the Cognos analytics 'workarea' folder.
Steps:
1. Logon to the Cognos Analytics server
2. Browse to the fodler: <cognos_install_location>\wlp\usr\servers\cognosserver\workarea
3. As a precaution, create a backup of the contents of that folder
4. Delete the contents of the folder: workarea
5. Test.
Related Information
Document Location
Worldwide
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Document Information
Modified date:
23 May 2019
UID
ibm10885456