IBM Support

OLAP connection to Microsoft SSAS 2012 fails: XOD-CON-0001

Troubleshooting


Problem

This document addresses the issue whereby, after an upgrade to Cognos, the OLAP connection for Microsoft SSAS cubes fail with the error message...
XOD-CON-0001 Failed to connect to the OLE DB provider (Microsoft Analysis Services 2012) and server (<servername>). The data provider returned and error message "CCLAsserError: CCL_ASSERT(NULL!=m_pIDBInitialize);".

Cause

User upgraded system and moved drivers over to new Cognos environment but did not install MSSAS client tools.
Also check if version of MSSAS is compatible with version of Cognos used.

Resolving The Problem

Here are the steps to resolve the issue...
  1. Check that the steps from the Microsoft Analysis Services Data Sources set-up documentation has been followed correctly.
  2. Install the Microsoft SSAS 2012 SDK client tools from the Microsoft website on the upgraded server
  3. Check the drivers folder to ensure all the required Microsoft drivers are present
  4. Recreate the data source connections.
  5. Test the connection from Cognos Administration Console

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.0.x, 11.1.x","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
24 May 2019

UID

ibm10885438