Troubleshooting
Problem
When you drill through from a dashboard to a detailed report, you notice that the drill through only works on first attempt.
After returning to the dashboard and trying to drill through again, the drill through does not work, as well as the cognos environment itself. The 'Team Content' folder does not show again. The whole session seems to be lost.
After returning to the dashboard and trying to drill through again, the drill through does not work, as well as the cognos environment itself. The 'Team Content' folder does not show again. The whole session seems to be lost.
Cause
The main cause is that the HTTP header became too large.
A second cause can be that the Web Server IIS 8.5 + is configured with HTTP/2.
A second cause can be that the Web Server IIS 8.5 + is configured with HTTP/2.
Resolving The Problem
Adjust the 'MaxFieldLength' and 'MaxRequestBytes' in the IIS webserver, described on the following link: https://support.microsoft.com/af-za/help/2020943/http-400-bad-request-request-header-too-long-response-to-http-request
IIS supports HTTP/2 only with TLS, and basically, when it is not supported, it falls down to HTTP/1.1 Check below documentation for further details : https://docs.microsoft.com/en-us/iis/get-started/whats-new-in-iis-10/http2-on-iis
Related Information
Document Location
Worldwide
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"Dashboard;Drill Through;","Platform":[{"code":"PF033","label":"Windows"}],"Version":"11.0.09;11.0.10;11.0.11;11.0.12","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
Was this topic helpful?
Document Information
Modified date:
21 May 2019
UID
ibm10885180