IBM Support

Under Administration Console => Status => System => the services of Dispatcher are shown in Unavailable state

Troubleshooting


Problem

In a distributed install consisting of multiple dispatcher on multiple server , the Manage>Administration Console>Status => System show various or all services as with status Unavailable
 

Symptom

When you have a single dispatcher installation the issue does not happen

Cause

The cogstartup.xml file in the directory configuration include a wrong hostname entry.

Environment

Issue happen only in distributed install

Diagnosing The Problem

Manage => Administration Console => Status => System => the services of Dispatcher are shown in Unavailable state
When having a distributed install just stop all but one instance and note the error does not happen.

Resolving The Problem

With an XML Editor open the cogstartup.xml file from the configuration directory of each instance.
Find the following in approx. line 34
<crn:parameter name="hostName">
    <crn:value xsi:type="xsd:string">your_hostname</crn:value>
  </crn:parameter>
Verify if this hostname is correct. Use the command hostname on Windows and Unix/Linux to find out the correct hostname. Replace the setting, save and restart Cognos to take modification into account.

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"Administration Console","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"11.0.*, 11.1.*","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Product Synonym

COGADMIN

Document Information

Modified date:
21 May 2019

UID

ibm10885096