IBM Support

Cognos jobs stuck at Executing state for a long time.

Troubleshooting


Problem

Several random jobs get stuck in Executing state and there is no pattern observed as some jobs process successfully and some not.
If the reports that are present in the affected jobs are run interactively, then it runs fine without any issue.
 

Symptom

Both restarting of Cognos services and rebooting of the servers does not help.
Also running the NC_DROP script does not resolve the issue.

Cause

Teradata throws a prompt box and the BiBus does not know how to respond, causing the process to hang.

Environment

This issue seems to affect when there are Teradata data source connections within the environment.

Diagnosing The Problem

Capture dumps for BIBus and Java processes and send to IBM Cognos Support for analysis.
To capture the BIBus dumps, logs should be checked for fetching PID of the BiBusTKServerMain process for the reports those are stuck in Executing state.
Once PID is obtained from logs, open Task Manager and for the corresponding PIDs for the BiBusTKServerMain processes, right click and click on “Create dump file”. This will create a dump file and its location will be shown in the subsequent dialogue box. Ensure to capture the dump file for all the BiBusTKServerMain processes and send it to Support.
Similarly, find the dispatcher Java processes in Windows Task Manager, right click and click on “Create dump file”. This will create a dump file and its location will be shown in the subsequent dialogue box. Send the dump files to Support.
If dump file analysis shows as below, then it indicates that the BIBus process hangs due to a setting in Teradata database called "Run in Quiet Mode”:
1 Id: 1abc.7c34 Suspend: 0 Teb: fffd8000 Unfrozen
 # ChildEBP RetAddr
00 0167dca4 76a4d846 user32!NtUserWaitMessage+0x15
01 0167dce0 76a4da5c user32!DialogBox2+0x222
02 0167dd0c 76a7f7d0 user32!InternalDialogBox+0xe5
03 0167ddc0 76a7faac user32!SoftModalMessageBox+0x757
04 0167df18 76a7fbaf user32!MessageBoxWorker+0x269
05 0167df84 76a7fc2e user32!MessageBoxTimeoutW+0x52
06 0167dfb8 76a7fd81 user32!MessageBoxTimeoutA+0x76
07 0167dfd8 76a7fdc6 user32!MessageBoxExA+0x1b
*** ERROR: Symbol file could not be found. Defaulted to export symbols for tdata32.dll -
08 0167dff4 193ad5ef user32!MessageBoxA+0x18
WARNING: Stack unwind information not available. Following frames may be wrong.
09 0167e080 193b43c3 tdata32!SQLDisconnect+0x403af
0a 0167e0a8 1936d3f0 tdata32!SQLDisconnect+0x47183
*** WARNING: symbols timestamp is wrong 0x4ce7c91e 0x4ce7b964 for odbc32.dll
0b 0167e0c0 5f5fdb6b tdata32!SQLDisconnect+0x1b0
0c 227e9200 1c270230 odbc32!bCheckAsyncConn+0x19
0d 227e920c 00000000 0x1c270230

Resolving The Problem

Enable "Run in Quiet Mode" in the DSN for the Teradata ODBC driver.
Note : Even though the affected reports/jobs do not use Teradata data source connections, still if there are any Teradata connections within the same Cognos environment, then this setting needs to be enabled in case the same issue is encountered.

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Component":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
17 May 2019

UID

ibm10884862