Troubleshooting
Problem
User logs onto Citrix Storefront website. User is presented with a 'Controller' icon. User clicks on the icon.
This triggers the Citrix client to open, and it appears that the Controller client will soon start launching. However, nothing happens after that.
- The Controller client does not appear
- The user is not prompted to logon/authenticate to Controller.
The problem only affects one user. It may appear intermittent.
Symptom
The Controller client does not appear, after clicking the Citrix icon.
Cause
In the previous session of Controller, the user has moved their Controller client window to a portion of the screen 'real estate' that no longer exists.
- By default, Controller remembers the position of the screen
- Therefore, Windows is now displaying the Controller client on an 'invisible' portion of the screen (for example on a monitor that is no longer plugged in).
The problem may appear intermittent, because the windows position is saved inside the Windows user profile.
- If you have multiple Citrix servers then the position may be 'good' on one Citrix server's Windows user profile but 'bad' on the other server's profile.
Example:
Imagine a scenario where a user runs Controller when their laptop:
- Sometimes uses their built-in laptop display only (for example 1366 x 768 resolution)
- Sometimes uses an external full HD (1920 x 1080) monitor, with the laptop lid closed
- Sometimes uses an external full HD (1920 x 1080) monitor, with the laptop lid open (therefore two different monitor/displays)
Because of this, the user may move the Controller client window positions to positions on the screen which (next time they launch Controller) do not exist.
- For example, they may have moved the Controller client to the right-hand screen (monitor #2) in the previous session
- If they reconnect to Controller, by default it will try to re-launch the client in the same position (monitor #2). If this monitor is unplugged, the user cannot see the client program.
TIP: For more information, see separate IBM Technote #1078377.
Environment
The end user changes their display (for example monitors / screen size) from time to time.
- For example, they may work from home with no external monitor
- But in the office, they may plug in an external monitor.
Resolving The Problem
Fix:
Modify the 'bad' end user's settings, so that it stops Controller from remembering screen positions
- In other words, for this 'bad' user only (per user setting) Controller will no longer remember/save the location/size of Windows positions.
Steps:
Each individual user should do the following:
1. Click "Maintain / User / Personal Defaults" then click tab "Layout (2)"
2. Untick the box 'Save Window Size':
3. Click Save
4. Logoff from Controller, and re-launch the Controller client.
===================================================
NOTE: The above 'Save Windows Size' change is stored inside the database, inside the 'xconfig' table. It is recorded separately for each individual user:
Therefore:
- Each end user must make this change separately
- They must repeat the change for each separate database that they use (for example 'production', 'test' and so on).
Workaround:
Plug in the same monitor/display that the end user used in the previous successful use of Controller client.
Related Information
Document Location
Worldwide
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSMRTZ","label":"IBM Cognos Controller on Cloud"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
12 October 2021
UID
ibm10884838