IBM Support

"Idle timer expired" message when using rich tier of Planning Analytics on Cloud, if user does not press keyboard or mouse for over 30 minutes

Troubleshooting


Problem

User connects to the Remote Desktop Gateway (by using their RDP file).
  • This launches Planning Analytics rich tier (on IBM cloud).
User performs work on their PA rich tier, for example:
  • run the hosted desktop applications
  • and/or manage files in the shared folder.
After a while, the user takes a break (for example, goes to lunch). User returns to their PC. A message is on the screen.

Symptom

image-20190516133928-1
Idle timer expired
Session has been idle over its time limit.
It will be disconnected in 2 minutes.
Press any key now to continue session.

Cause

User has not pressed a key (on their keyboard) or moved their mouse inside the Rich Tier session, for a length of time longer than the timeout value (30 minutes).
More Information:
All Planning-Analytics-on-Cloud (PAoC) rich tier servers are configured to have a Microsoft remote session 'active but idle' timeout of 30 minutes.
  • If this value is exceeded (the user has not used their keyboard/mouse inside the Planning Analytics programs), then users will see the message
Soon afterwards, the user's session will become 'disconnected'.
  • This means that it will continue to run (in the background, on the IBM Cloud servers) but the user will not see it on their screen.
  • If the user then re-launches Rich Tier then they will 'reconnect' with that existing/disconnected session, so the user will be able to carry on (in the system) from the same state (as they left it, when it was disconnected) with no loss of work/data.
For more information, see links at the end of this Technote.

Resolving The Problem

Fix:
This is by design.
  • TIP: For more information, see links at the end of this Technote.
More Information
IBM Cloud have deliberately implemented this for security reasons. The idle timeout has been enabled because of Security assessments and GDPR rules.
  • IBM Cloud will not allow these GPOs to be removed/changed modified
  • Therefore it is not possible to either (a) disable the timeout or (b) increase the timeout value.
Workaround:
There are several methods:
Method #1:
If the end user sees the message, they must click 'OK' (to acknowledge the message) then carry on with work.
Method #2:
If the user did not see the message, then their session will have been logged off.
  • Therefore they will need to re-launch their PAoC rich-tier session.
  • By doing this, they will reconnect to their old/disconnected session (and not lose any work).
In other words, when a session does time out:
  • Any applications open (on the remote desktop) will remain open and file share mappings will persist
  • The end user will need to reconnect to their RDP session using their modeler user and password.

Document Location

Worldwide

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Document Information

Modified date:
20 September 2021

UID

ibm10884708