IBM Support

Dispatcher status shows as Unknown in the Administration console Scorecard

Troubleshooting


Problem

In Cognos Administration  under the default scorecard view all dispatchers show up as available but when you click on the option to maximize the scorecard widget some of the application tier dispatchers show the server status as 'unknown'.
From this console we cannot determine if these dispatchers are working as the status is 'unknown' and the 'number of requests processed' is zero but the services all started sucessfully.

Cause

Issue was caused from copying the cogstartup.xml file from the configuration directory among the application tier installs in a distributed environment.
In the cogstartup.xml file the server name is captured in the xml which is not exposed in the Cognos Configuration GUI.  Therefore, when this file is copied from one server to another there is an incorrect reference in it for the host name as it is pointing to the host the file was copied from.

<crn:parameter name="hostName">

<crn:value xsi:type="xsd:string">serverA.ibm.com</crn:value>

</crn:parameter>

Resolving The Problem

1. Stop Cognos Analystics service on the problem server.
2. Rename the cogstartup.xml file in the configuration directory of the install to cogstartup.xml.OLD
3. Launch Cognos Configuration which will create a new empty cogstartup.xml with the correct hostname.
4. Reconfigure manually.
5. Start service

Document Location

Worldwide

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Document Information

Modified date:
26 April 2019

UID

ibm10882720