Troubleshooting
Problem
WMS pipelines missing after upgrading from 9.1 to 9.5
Symptom
- YFS_PIPELINE table do not have entries related to WMS-91
- Below error thrown while confirming a draft order
- YFS10297: YFS: No Pipeline is configured. [PipelineKey:WMS-Purchase-91]
Cause
Some factory setup data got deleted during upgrade to 9.5. Product team may change/delete the factory setup data during upgrade. It is advised that clients should not make use of the OOB pipelines in their implementation. Rather client should make a copy of these pipelines and edit as required and use it for their implementation to avoid these kind of issues. As a work around you may reload the deleted factory setup data.
Resolving The Problem
- Take a copy of the fc_migrator.xml, save as fc_migrator_fix.xml , from <95_INSTALL_DIR>/Migration/9.1/database/FactorySetup/XMLS
- Comment the sections related to added and changed (keep only deleted)
- Update DeleteEntity="N" for all the entries in fc_migrator_fix.xml
- Change directory to <95_INSTALL_DIR>/Migration/9.1/
- Execute <95_INSTALL_DIR>/bin>loadDefaults.cmd/.sh <95_INSTALL_DIR>/Migration/9.1/database/FactorySetup/XMLS/fc_migrator_fix.xml
- Restart the application server and rerun the scenario
Document Location
Worldwide
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Component":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"9.5","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]
Product Synonym
Sterling OMS; Sterling WMS
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Document Information
Modified date:
23 April 2019
UID
ibm10882152