IBM Support

Long delay (approx 10-15 mins) with a white screen, then "DPR-ERR-2002 Unable to execute the request because there were no connections..." error running Standard Report, caused by Sophos antivirus blocking BIBusTKServerMain.exe

Troubleshooting


Problem

User launches the main Controller client, and runs any standard report.
The report viewer screen opens, but it contains only white/blank screen. After a long delay (approximately 10+ minutes) an error appears.

Symptom

Client device screen:
image-20190417105057-1
DPR-ERR-2002: Unable to execute the request because there were no connections to the process available within the configured time limit
Event Viewer (Cognos Analytics server):
Faulting application name: BIBusTKServerMain.exe, version: 11.0.7.1,    
time stamp: 0x58f63325                                                  
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005                                              
Fault offset: 0x00000000                                                
Faulting process id: 0x2c80                                             
Faulting application start time: 0x01d4ee8b55c683b2                     
Faulting application path: C:\Program Files\ibm\cognos\analytics\bin\BIBusTKServerMain.exe                    
Faulting module path: unknown                                           
Report Id: d55842d1-c7b2-4d7e-aac3-38331161dcd1                         
Faulting package full name:                                             
Faulting package-relative application ID:                              

Cause

There are many possible causes for the generic 'DPR-ERR-2002' error.
  • Search through separate IBM Technotes for other possible causes.
This Technote specifically relates to the scenario where the cause is that the Cognos Analytics engine (which is powering the Controller standard reports) cannot successfully create ('spawn') the required process 'BIBusTKServerMain.exe'.
  • The reason is that each new 'BIBusTKServerMain.exe' process is getting killed (deleted) by the anti-virus (anti-malware) product (for example 'Sophos') a few seconds after it is created.

Environment

This problem has been seen when the Cognos Analytics server is hosted on a Windows server which has Sophos anti-virus installed.

Diagnosing The Problem

1. On the Cognos Analytics application server, launch 'Task Manager'
2. Click tab 'Details'
3. Notice that (when a standard report is run) a process 'BIBusTKServerMain.exe' is created, with a specific PID (for example 13720):
image-20190417112124-1
4. Initially the 'Status' will be set to:  Running
5. After 1-2 seconds, the status will change to 'Suspended'
6. A few seconds later, a new process 'BIBusTKServerMain.exe' is created, with a new PID (for example 13721), and is set to 'Running'
7. Again, after 1-2 seconds this changes to 'Suspended', and then disapears
8. Notice how steps 6-7 now repeat many times

Resolving The Problem

Fix:
Reconfigure third-party (non-IBM) software product (Sophos) to exclude BIBusTKServerMain.exe from being monitored.
  • Consult your third-party (non-IBM) software vendor (Sophos) for instructions on how to do this.
   
Workaround:
Uninstall/disable Sophos.

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.3.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}},{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
29 April 2019

UID

ibm10881534