Troubleshooting
Problem
Windows patches were applied over the weekend to the Cognos Analytics Windows servers. No reports will run now even after stopping and restarting Cognos services. In the cognosserver.log file we see an error: java.io.IOException Process BIBusTKServerMain.... failed to start properly
Symptom
No Cognos reports will run for any user including the Cognos Administrator. Eventually this error is issued:
DPR-ERR-2002 Unable to execute the request because there were no connections to the process available within the configured time limit
Cause
The anti-virus software was preventing the BIBUS process from spawning.
Resolving The Problem
Stop the anti-virus software on the Cognos Windows server. Run a report, and check in Task Manager to make sure the BIBUS process is running now. You can add an exception in the anti-virus software to exclude the Cognos installation directory from being checked.
Document Location
Worldwide
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"11.0.11, 11.0.12, 11.0.13","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
27 March 2019
UID
ibm10878763