IBM Support

The Cognos Analytics audit database is not capturing all the expected information

Troubleshooting


Problem

On checking the COGIPF_RUNREPORT table, the COGIPF_REPORTPATH and COGIPF_REPORTNAME columns are empty.

Cause

I've re-imported my packages into a Cognos environment and since then auditing is no longer being logged.

Diagnosing The Problem

 
The link had become broken between the report and package. If you open the report in edit mode, the message
The package has been updated. The report was updated and validated successfully

Resolving The Problem

After opening the report in Edit mode, you need to save it. Once done, the audit tables should now start to capture all the information.

A workaround is to untick the version control option whilst publishing the package from Framework Manager. This should ensure it is not retaining the version and it is always taking the latest package after the change.

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"11.0.x","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
22 March 2019

UID

ibm10876980