IBM Support

Unable to renew credentials on a Generic OpenID Connect namespace

Troubleshooting


Problem

When using a namespace with the type OpenID Connect - set up using the Generic connector you are not able to renew the trusted credentials from the Personal tab under My Preferences. After inputting username and password - there will be an error saying that the credentials are invalid. 

Cause

The default value for the Strategy under Scheduling Credentials is set to Credentials, in most cases this is not the correct setting.

Environment

IBMid, OKTA, Azure, Trustbuilder

Resolving The Problem

In the namespace configuration, change the strategy under Scheduling credentials from Credentials to ID token only 
Restart the Content Manager services for the changes to take affect. 
Attempt to Renew trusted credentials - the error will no longer persist and you will be able to renew credentials. 

Document Location

Worldwide

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Document Information

Modified date:
21 March 2019

UID

ibm10876938