IBM Support

Unable to connect to a database to set up auditing: IPFTEST-006

Troubleshooting


Problem

Testing and Audit database connection added to Cognos Configuration fails with error:

[ ERROR ] IPFTEST-006 Logging failed to connect to Database

Symptom

Database login has been confirmed to be correct confirming this is not the issue.

Cause

The Cognos Analytics Server installation does not have the required JDBC driver to connect to the Audit Database.

Resolving The Problem

1. Stop the Cognos Analytics 11 server and close Cognos Configuration.
 
2. Place a copy or the JDBC driver for the type of database the Audit database is located into the <cognos_analytics_install>/drivers directory
 
  • Tip: If Cognos Analytics is using the same Audit database you can copy the JDBC driver from the <cognos_analytics_install>/drivers directory
3. Start Cognos Configuration and confirm the Audit database tests successfully.

Document Location

Worldwide

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Document Information

Modified date:
29 June 2022

UID

ibm10876786