IBM Support

ILMT の概要画面のスキャンの状態に「古いカタログ」の表示がある。

Troubleshooting


Problem

ILMT の概要画面のスキャンの状態部分に「古いカタログ」の表示がある。
この表示を解消するために、どのような操作が必要となるかを確認したい。

Cause

ILMT サーバーより、エージェント(Bigfix クライアント)のソフトウェア・カタログのバージョンが古い場合に、「古いカタログ」の状態が発生します。

Resolving The Problem

「古いカタログ」の状態は、ソフトウェア・カタログの更新処理を実施した場合に発生する可能性があります。
対応方法は以下となります。
1)
ILMTサーバー上のソフトウェア・カタログ情報がエージェント(Bigfixクライアント)に伝播されるまで時間がかかる場合があります。
ソフトウェア・カタログの更新操作を実行した後、数日(2,3日)程度時間を置いて、状態が改善されていることをご確認ください。
2)
時間が経過した後にも、継続して「古いカタログ」の状態が発生している場合には、ILMTサーバーとエージェント(Bigfixクライアント)のソフトウェア・カタログ情報に差異がないかご確認ください。
確認方法は以下となります。
まず、ILMTサーバー側のカタログバージョン情報を確認します。
a. ILMTサーバーにログインして、管理 > カタログのアップロード を開きます。
b. ソフトウェア・カタログ:カタログのアップロード画面の下部の詳細を展開して、現在のカタログの内部バージョンの表示を確認します。
次に、エージェント(Bigfix クライアント)のソフトウェア・カタログ情報を確認します。
c. Bigfix コンソールにログインして、サイト > 外部サイト > IBM License Reporting(ILMT)v9 > 分析:ソフトウェア・スキャンのステータスを開きます。
d. この分析が「アクティブ化されていない」状態の場合には、「アクティブ化」をクリックします。
e. 結果タブを開き、各コンピューターの「カタログのバージョン」の表示を確認します。
 b.で確認した現在のカタログの内部バージョンとの差異を確認します。
ILMT サーバーとエージェント(Bigfix クライアント)間のカタログバージョン情報に差異がある場合には、項目3)をご参照ください。
ILMT サーバーとエージェント(Bigfix クライアント)間のカタログバージョン情報に差異が無い場合には、項目4)をご参照ください。

3)
エージェント(Bigfix クライアント)側のソフトウェア・カタログを更新します。
手順は、以下のようになります。
a. ILMT サーバー にログインして、管理 > カタログのアップロード開きます。
b. 疑問符記号(?)をクリックします。
 次に、「カタログのダウンロード用 Fixlet」をクリックします。 catalog_download.bes ファイルを保存する場所を選択し、「保存」をクリックします。
c. b.で保存したファイルを、BigFix コンソールがインストールされているコンピューターにファイルをコピーします。
d. このファイルを Bigfix コンソールにインポートします。
 Bigfix コンソールにログインして、「ファイル」 > 「インポート」をクリックします。
    catalog_download.bes ファイルを選択して、「開く」をクリックして、インポートします。
e. 左ペインで、「サイト」 > 「マスター・アクション・サイト」 > 「Fixlet とタスク」をクリックします。右上のペインに、使用可能な Fixlet のリストが開きます。
f. 「カタログのダウンロード (バージョン: version) (Catalog Download (Version: version))」を選択し、「アクションの実行」をクリックします。
g. ソフトウェア・カタログのバージョンが古いコンピューターを選択して、「OK」をクリックします。
4)
エージェント(Bigfix クライアント)側のカタログ情報を表示するためのファイルを再作成します。
a. 「古いカタログ」の状態が発生しているコンピューターにログインします。
b. 以下のファイルを別の場所に移動します。 例:c:\temp等
<windows>
C:\Program Files (x86)\BigFix Enterprise\BES Client\LMT\CIT\catalog.xml
C:\Program Files (x86)\BigFix Enterprise\BES Client\LMT\CIT\catalog_version.info
<unix>
/var/opt/BESClient/LMT/CIT/catalog.xml
/var/opt/BESClient/LMT/CIT/catalog_version.info
c. 上記の項目3)の手順を実行します。
 

Document Location

Worldwide

[{"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SS8JFY","label":"IBM License Metric Tool"},"Component":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"9.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
26 April 2021

UID

ibm10869442