IBM Support

ServeRAID ISPR bootup errors - Servers and IntelliStation

Troubleshooting


Problem

ServeRAID ISPR bootup errors: this document describes ServeRAID Interrupt Status Port Register (ISPR) error code procedures.

Resolving The Problem

ServeRAID Interrupt Status Port Register (ISPR) error code procedures

During power-on self-test (POST), the ServeRAID adapter or controller compares the stored configuration information to the configuration that is actually present. If a discrepancy exists, one or more status messages appear after POST completes, but before the operating system loads. The ISPR (Interrupt Status Port Register) code identifies the ServeRAID adapter / controller state.

Note: Your ServeRAID BIOS and firmware version may be different from the ones shown in the following examples. Click here to review the ServeRAID software matrix.

Click here to troubleshoot other ServeRAID errors that occur during POST/startup.


Example 1: No configuration errors exist

If there is no POST error or configuration error message, the BIOS screen resembles the sample shown below.

+--------------------------------------------------------------------------+
__________________________________
IBM ServeRAID BIOS Copyright IBM
Corp. 1995, 2001
Ver: 3.00.12 08/14/2000, 2001
__________________________________
Press Ctrl+I to access the Mini-Configuration Program.
Initializing ServeRAID Controller 1 in Slot 1.
Power-on self-test can take up to 59 Second(s) -- test Passed.
Drive configuration can take up to 6 Minute(s) 0 Second(s) -- test Passed.
ServeRAID Firmware Version:2.82.00
No logical drives found; none are installed.
Non-Disk SCSI Devices Found: CD-ROM 0, Tape 0, Removable-media 0, Other 1.
BIOS not loaded no devices found - Installation stopped.
+----------------------------------------------------------------------------+


Example 2: Configuration errors exist

If there is a POST error message, the BIOS screen resembles the sample shown below.

NOTE: The characters XXXX indicate the POST (ISPR) error code.

+--------------------------------------------------------------------------+
__________________________________
IBM ServeRAID BIOS Copyright IBM
Corp. 1995, 2001
Ver: 3.00.12 08/14/2000, 2001
__________________________________
Press Ctrl+I to access the Mini-Configuration Program.
Initializing ServeRAID Controller 1 in Slot 1.
Power-on self-test can take up to 59 Second(s) -- test Failed.
Controller is not responding properly - Run Diagnostics.
Error Code: XXXX-YY

BIOS not loaded no devices found - Installation stopped.
+----------------------------------------------------------------------------+

ServeRAID POST (ISPR) error codes
Error code
Recommended action
1XXX (Microcode checksum error)
Replace the ServeRAID controller.
2XXX - 5XXX (Code DRAM error)
  1. Install download jumpers.
  2. Flash ServeRAID controller to the latest BIOS and firmware. Click here to download the latest BIOS and firmware
  3. Remove jumpers.
  4. If still fails, replace the ServeRAID controller.
6XXX (Cache DRAM error) - ServeRAID-4H only
  1. Reseat daughter card.
  2. Install download jumpers.
  3. Flash ServeRAID controller to the latest BIOS and firmware. Click here to download the latest BIOS and firmware
  4. Remove jumpers.
  5. If still fails, replace the ServeRAID controller.
7XXX - 8XXX (Host/Local PCI bus interface error)
  1. Install download jumpers.
  2. Flash ServeRAID controller to the latest BIOS and firmware. Click here to download the latest BIOS and firmware
  3. Remove jumpers.
  4. If still fails, replace the ServeRAID controller.

9ZXX - BZXX (SCSI bus error)

The second digit Z refers to the specific channel or channels that caused the error.

Click here to review explanation of SCSI channel codes

NOTE:

  • ServeRAID-4H controllers have 4 channels
  • ServeRAID-4M and 4Mx controllers have 2 channels
  • ServeRAID-4L and 4Lx controllers have only 1 channel
  • Refer to the Hardware Maintenance Manual (HMM) specific to your system for SCSI cabling details

Possible causes:

  1. SCSI cabling
  2. SCSI termination
  3. SCSI backplane
  4. Hard disk drive
  5. ServeRAID controller

Action:

  1. Isolate problem between the SCSI subsystem and the controller by disconnecting all SCSI cables from the suspect card, and reboot.
  2. CAUTION: The ServeRAID controller will detect a configuration change. Do not press F5 to Save Changes. Doing so will change the configuration. Instead, press F10 to bypass any options to this effect.
  3. If the original ISPR error is still present after disconnecting all SCSI cables and rebooting, reseat the controller. If this still fails, replace the controller.
  4. If the ISPR code is EF10 after disconnecting the cables, then identify which channel is causing the error by the second digit (Z) of the original ISPR code as indicated in the SCSI channel code table (left).
    1. Confirm that the channel(s) identified from the SCSI channel code (Z) are the cause of the error by verifying that the error presents itself ONLY when the offending channel is reconnected.
    2. Check termination of the identified channel.
    3. Check for proper backplane jumper configuration.
    4. Check for proper cabling configuration in systems that use DASD status cables and I2C cables.
    5. Reconnect all cables removed in step 1 above.
    6. Disconnect one drive at a time attached to the channel identified above, then reboot to determine which drive is causing the error.
    7. Replace the SCSI cable attached to the identified channel.
    8. Replace the SCSI backplane attached to the identified channel.
EF10 (Default ISPR) This is the default ISPR code. There is no error present.
EFFE (Firmware code corrupt or download jumpers are in place)
FFFF or other code not listed

Possible causes:

  1. SCSI cabling
  2. SCSI termination
  3. SCSI backplane
  4. Hard disk drive
  5. ServeRAID controller

Action:

  1. Isolate problem between the SCSI subsystem and the controller by disconnecting all SCSI cables from the suspect card, and reboot.
  2. CAUTION: The ServeRAID controller will detect a configuration change. Do not press F5 to Save Changes. Doing so will change the configuration. Instead, press F10 to bypass any options to this effect.
  3. If the original ISPR error is still present after disconnecting all SCSI cables and rebooting, reseat the controller. If this still fails, replace the controller.
  4. If the ISPR code is EF10 after disconnecting the cables, then identify which channel is causing the error by the second digit (Z) of the original ISPR code as indicated in the SCSI channel code table (left, under "9ZXX - BZXX SCSI bus error").
    1. Confirm that the channel(s) identified from the SCSI channel code (Z) are the cause of the error by verifying that the error presents itself ONLY when the offending channel is reconnected.
    2. Check termination of the identified channel.
    3. Check for proper backplane jumper configuration.
    4. Check for proper cabling configuration in systems that use DASD status cables and I2C cables.
    5. Reconnect all cables removed in step 1 above.
    6. Disconnect one drive at a time attached to the channel identified above, then reboot to determine which drive is causing the error.
    7. Replace the SCSI cable attached to the identified channel.
    8. Replace the SCSI backplane attached to the identified channel.

Note:

  • Do not replace the ServeRAID controller or an imbedded controller on a system board unless such a replacement is indicated in the recommended actions.
  • When the ServeRAID controller requires your input, a list of function keys will appear below the message.
  • Where the "Action" information tells you to start the IBM ServeRAID configuration program, insert the "IBM ServeRAID Configuration CD" into the CD-ROM drive, then restart the server. The action column also provides general information about the message.
  • Where SID and ch appear in these messages, SID shows the SCSI ID for the device, and ch shows the channel to which the device is attached.
  • Where m or n appears in these messages, a number will appear in the actual message.
SCSI channel codes
SCSI channel code (Z)
Description
1
Channel 1
2
Channel 2
3
Channel 1 & 2
4
Channel 3
5
Channel 1 & 3
6
Channel 2 & 3
7
Channel 1, 2, & 3
8
Channel 4
9
Channel 1 & 4
A
Channel 2 & 4
B
Channel 1, 2, & 4
C
Channel 3 & 4
D
Channel 1, 3, & 4
E
Channel 2, 3, & 4
F
Channel 1, 2, 3, & 4

Additional information

Document Location

Worldwide

Operating System

System x:Operating system independent / None

IntelliStation Pro:Operating system independent / None

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Document Information

Modified date:
28 January 2019

UID

ibm1MIGR-40379