IBM Support

Guardium Query Rewrite Builder Menu Missing From Collector After Applying License On Central Manager

Troubleshooting


Problem

On an existing federated environment, after applying either of the following licenses which includes Query Rewrite capabilities, the GUI admin user is unable to see the Query Rewrite Builder menu item under Protect-->Security Policies on the Collector Managed Unit:
  • IBM Security Guardium Advanced Activity Monitor for Databases
  • IBM Security Guardium Data Protection for Data Warehouses

Symptom

Query Rewrite Builder menu item under Protect-->Security Policies on the Collector is missing.

Cause

Either of the above licenses should display the Query Rewrite Builder menu item on the Collector if either license installed successfully on the Central Manager.  This is caused by the new license capabilities not yet propagated to the MU.

Environment

v10

Diagnosing The Problem

If you have either of the above licenses installed successfully on the CM and the user you are logging in as has an admin role on the Collector Managed Unit and you still can't see the Query Rewrite Builder menu, then you are being impacted by this issue.

Resolving The Problem

  1. On the Central Manager GUI, navigate to Manage->Central Management
  2. Click on the Refresh Unit Info icon to the left-most of the impacted Collector Managed Unit
  3. When the refresh completes, log back into the Collector Managed Unit and you should now be able to see the Query Rewrite Builder menu

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Component":"Query Rewrite;Query Rewrite Builder;license;product key","Platform":[{"code":"PF016","label":"Linux"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
17 January 2019

UID

ibm10795714