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Office365 HasActiveSyncDevicePartnership reset for MaaS360 record sync

Troubleshooting


Problem

In MaaS360 integration to Office365 via Cloud Extender tool, HasActiveSyncDevicePartnership is a critical field since record visibility is dependent on this flag. In migration scenario from on-prem exchange to Office365, HasActiveSyncDevicePartnership flag is left to false once the mailbox is migrated. This "False" status causes ActiveSync records from Office365 mailbox to not with MaaS360 Cloud Extender. Cloud Extender tool has script build in which will automatically refresh this flag every 7 days. This document will assist in troubleshooting HasActiveSyncDevicePartnership flag as possible cause for records not to be visible on MaaS360 portal but being created or migrated over from on-prem exchange. 

Cause

  1. Click Start, point to All Programs, click Accessories, click Windows PowerShell, and then click Windows PowerShell.
  2. Run the following command:
      $LiveCred = Get-Credential
    2013-06-07 14 48 48-Windows PowerShell
    In the Windows PowerShell Credential Request window, type the credentials of an account in your cloud-based organization. Then, click OK. Run the following command:
      $Session = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri https://ps.outlook.com/powershell/ -Credential $LiveCred -Authentication Basic -AllowRedirection
    2013-06-07 15 01 51-Windows PowerShell
    Run the following command:
      Import-PSSession $Session  
    Commands that are used in the cloud-based service will now be imported into the client-side session of your local computer, as tracked by a progress bar. When this process is complete, you can run these commands.
    2013-06-07 15 04 58-Windows PowerShell
    Run: Get-CASMailbox -Identity <email> | fl 'HasActiveSyncDevicePartnership'
    2013-06-07 15 24 05-Windows PowerShell

    If this command returns 'False', it suggests that no ActiveSync devices are associated with the user's mailbox. To see if an ActiveSync record(s) ACTUALLY exists, you can use the following command:

    Get-ActiveSyncDevices -Mailbox <email> | fl 'DeviceID'

    2013-06-07 15 24 55-Windows PowerShell

    If DeviceIDs are returned, you can be sure that the mailbox has an ActiveSync record (2 in the above case). If the flag is correct, you should see no results returned.

    2013-06-07 15 26 06-Windows PowerShell

Resolving The Problem

There are 2 possible ways to resolve this behavior. 
1. Remove one or all activesync device record(s) from the mailbox and allow the device to resync with Office365. Resyncing device typically sets the flag to true and MaaS360 Cloud Extender will evaluate the mailbox on next evaluation cycle. 
2. If there are many mailboxes display this behavior or HasActiveSyncPartnership Flag being false but mailbox actually has device records then following script can be ran to re-evaluate all mailboxes. 
Get-CASMailbox -ResultSize:Unlimited -RecalculateHasActiveSyncDevicePartnership
image2016-2-10 10 10 11

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Document Information

Modified date:
07 January 2019

UID

ibm10794141