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Custom search screen throws "IN clause SQL generation error, More records than max allowed encountered" when trying to search for Count tasks

Question & Answer


Question

Why does search screen throw the error when we you are using the getTaskList API to retrieve records on your custom search console ?

Cause

With the following input XML to getTaskList API. The query to the table YFS_TASK_TYPE does not have a OrganizationCode filter set at TaskType level, hence it retrieves all the records for activity group Count and hence an error is seen.

<Task EnterpriseKey="DEFAULT" IgnoreOrdering="Y" MaximumRecords="200" OrganizationCode="N1" NodeKey="N1">
<TaskReferences CountRequestKey="2018112615113770812345" CountRequestNo="C1"/>
ActivityGroupId="COUNT"/>
</Task>

Answer

You need to pass the Organization code at Task Type level as per the input below:

<Task EnterpriseKey="DEFAULT" IgnoreOrdering="Y" MaximumRecords="200" OrganizationCode="N1" NodeKey="N1">
<TaskReferences CountRequestKey="201811261511377087066189" CountRequestNo="873481"/>
<TaskType OrganizationCode="N1" ActivityGroupId="COUNT"/>
</Task>

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Component":"Warehouse Management","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"9.4","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
31 December 2018

UID

ibm10791951