Troubleshooting
Problem
We moved our iBase Scheduler to a different system. Our batch import specifications connect to an OLE-DB data source (SQL Server). While the batch imports run fine on the old system, on the new system we get the following error:
Provider cannot be found. It may not be properly installed.
Provider=<Provider>;Integrated Security=SSPI;Persist Security Info=False;User ID="";Initial Catalog=<DB name>;Data Source=<SQL Server>;Initial File Name="";Server SPN="";DataSourceName=<DB table>;
Error #3706 occurred in:
ADODB.Connection
idImportSource:OpenSource
idImport:Import
FBatchImport:RunImports
Where:
<Provider> is the short name for your OLE-DB Provider
<DB name> is the database name
<SQL Server> is the SQL Server hostname
<DB table> is the table referenced in the database
Cause
At least one of the import specifications is trying to connect to the SQL Server using an OLE DB provider that is not available on the new system. The provider configured in the Import Specification requires a download of the OLE DB drivers for the specified provider. There are different SQL Server providers. Here is a link to an article listing the generations of OLE DB drivers to connect to a SQL Server database:
Different generations of OLE DB Drivers
Resolving The Problem
Either download the specific OLE DB driver for the configured provider, or update your i2 iBase import specification to use a provider already configured on your system.
On a Windows system, to see what SQL Server drivers are already available on your system, do the following:
- search for "ODBC" to launch the ODBC Data Soure Administration tool
- Click on the Drivers tab to see the available drivers on your system
From the System DSN tab, you can "Add..." a new Data Source definition to connect to your SQL Server.
Related Information
Historical Number
TS001656448
Product Synonym
ibase
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Document Information
Modified date:
17 December 2018
UID
ibm10791689