Troubleshooting
Problem
User launches IBM Cognos Controller Web. An error appears.
Symptom
Server is not reachable or still initializing, please refresh the page in a few seconds
Cause
There are several known causes for this error:
- Scenario #1 - URL using incorrect syntax (for example NetBIOS name instead of FQDN)
- The used URL must match the nomenclature
Example:
In one real-life example, when using NetBIOS: http://vbracont8ap9:9080
However, if change the URL to FQDN: http://vbracont8ap9.hursley.ibm.com:9080
- Scenario #2 - IBM Cognos Controller Web configuration file 'com.ibm.cognos.fcm.web.properties' contains incorrect settings
- Example: In one real-life customer example, it mistakenly contained two entries for ccrwsUrl
- Scenario #3 - IBM Cognos Controller Web configuration file 'config.js' contains incorrect settings and/or is corrupted
- Example #1: In one real-life customer example, the values of the server names were mistakenly wrapped with curly brackets {}
- For example: "host": "{myserver.companyname.com}",
- Example #2: In a different real-life example, the file was corrupted
- For more details, see separate IBM technote #6258223
- Example #1: In one real-life customer example, the values of the server names were mistakenly wrapped with curly brackets {}
- Scenario #4 - Incorrect TCP port setting ("httpPort") inside 'server.xml'
- For more details, see separate IBM technote #0882548
- Scenario #5 - Incorrect setting "JAVA_HOME" inside 'server.env'
- For more details, see separate IBM technote #0888049
- Scenario #6 - IBM Cognos Controller application server's IIS (webserver) has been configured to use Windows (not the default 'anonymous') authentication
- For more details, see separate IBM technote #1125087
- Scenario #7 - The fcm.web server has become corrupted
- For more details, see separate IBM technote #1171456
- Scenario #8 - Miss-configuration of HTTPS (SSL/TLS) settings
- For more details, see separate IBM technotes #1075287 & 6210360
- Scenario #9 - IBM Cognos Controller Web configuration file 'server.xml' is missing the keystore reference
- For more details, see separate IBM technote #6846611
Resolving The Problem
Scenario #1
Make sure users use the correct URL to connect to IBM Cognos Controller.
Example (Controller 10.4): http://servername.companyname.com:9080
Scenario #2
Make sure that the IBM Cognos Controller Web configuration file 'com.ibm.cognos.fcm.web.properties' (located on the IBM Cognos Controller application server) has been correctly configured.
Scenario #3
Make sure that the IBM Cognos Controller Web configuration file 'config.js' (located on the IBM Cognos Controller application server) has been correctly configured.
- Example #1: In one real-life situation it was necessary to remove the curly brackets {} around the server name.
- In other words, the correct value was: "host": "{myserver.companyname.com}",
- For more details, see separate IBM technote #0791535
- Example #2: In a different real-life situation it was necessary to replace the existing (bad) config.js with a fresh/default version, then reconfigure the new version.
- For more details, see separate IBM technote #6258223
Scenario #4
Reconfigure the file 'server.xml' with the correct settings for 'httpPort'.
- For more details, see separate IBM technote #0882548
Scenario #5
Reconfigure the file 'server.env' with the correct settings for 'JAVA_HOME'.
- For more details, see separate IBM technote #0888049
Scenario #6
- However, leave the Cognos Analytics (CA) IIS portion to still use Windows authentication.
- For more details, see separate IBM technote #1125087
- For more details, see separate IBM technote #1171456
Scenario #8
- For more details, see separate IBM technotes #1075287 & 6210360
Scenario #9
- For more details, see separate IBM technote #6846611
Related Information
0791535 - How to install IBM Cognos Controller Web
0882548 - "Server is not reachable or still initializing, please refresh the pa…
0888049 - "Server is not reachable or still initializing, please refresh the pa…
1125087 - "Server is not reachable or still initializing, please refresh the pa…
1171456 - "Server is not reachable or still initializing..." when launch IBM Co…
6210360 - ** Troubleshooting ** "Server is not reachable or still initializing …
6258223 - "Server is not reachable or still initializing" (& "Faulting applicat…
"Server is not reachable or still initializing, please refresh the page in a fe…
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Document Information
Modified date:
09 December 2022
UID
ibm10791129