Troubleshooting
Problem
It has been observed under certain circumstances that updating an already published catalog can result in an inability to access any resources within the catalog.
Symptom
Requests made to resources within the catalog will fail with a 404 response code.
Cause
The catalog is not being configured correctly after a dynamic reconfiguration within the gateway server.
Diagnosing The Problem
Using the instructions located in MustGather data for IBM API Connect Gateway , gather the required logs to debug the issue.
Within the logs for the dynamic-gateway-service pod or the gwd-log.log (collected from MustGather), look for evidence of the following messages:
[apiconnect][0x88e000df][apic-gw-service][error] apic-gw-service(default): tid(244): Error triggering 911 scenario: TypeError: Cannot read property 'client_id' of undefined
[apiconnect][0x88e00127][apic-gw-service][error] apic-gw-service(default): tid(244): Stack trace for previous error:
at APIMManager.getAccessToken (/root/gateway-director/lib/management/apim/APIMManager.js:167:45)
at APIMManager.trigger911 (/root/gateway-director/lib/management/apim/APIMManager.js:783:38)
at <anonymous>
Resolving The Problem
This issue is fixed in 2018.4.1.2 which can be found on IBM Fix Central
As a temporary workaround, the following actions can be taken to restore the correct catalog configuration:
- Create and publish a brand new catalog
- Remove and re-attach the gateway
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Document Information
Modified date:
05 February 2019
UID
ibm10743141