IBM Support

Cognos Administration Schedules remain in Waiting Status when using Google Chrome browser

Troubleshooting


Problem

Schedules that have been completed remain in Waiting status and also have a completion time and cannot be cancelled. 

Cause

In Table NC_TSE_STATE_MAP, there are three old entries with Status = 15 and Executing = 1. The status fails to update once the schedule has finished running.

Resolving The Problem

Steps:

1. Run Script:

Microsoft SQL Server Script:

begin transaction;
create table #tempnc (TASK_ID CHAR(45) PRIMARY KEY);
insert into #tempnc (TASK_ID) SELECT TOP <NUMBER_RECORDS_TOBE_REMOVED> t1.TASK_ID from <dbo>.NC_TSE_STATE_MAP as t1, <dbo>.NC_TASK_QUEUE as t2 where t1.TASK_ID = t2.TASK_ID and t1.STATUS >= 15 and ((t2.DATE_ENTERED + 86400000) <= (SELECT MAX(DATE_ENTERED) FROM <dbo>.NC_TASK_QUEUE));

delete from <dbo>.NC_TASK_ANCESTOR_STOREIDS where TASK_ID IN (select TASK_ID from #tempnc);
delete from <dbo>.NC_TASK_HISTORY_DETAIL where TASK_ID IN (select TASK_ID from #tempnc);
delete from <dbo>.NC_TASK_QUEUE where TASK_ID IN (select TASK_ID from #tempnc);
delete from <dbo>.NC_TSE_STATE_MAP where TASK_ID IN (select TASK_ID from #tempnc);
delete from <dbo>.NC_TASK_PROPERTY where TASK_ID IN (select TASK_ID from #tempnc);

drop table #tempnc;
commit transaction;

2. Clear browsing cache and cookies in Google Chrome and refresh page.

Waiting schedules should now disappear from the Current Activities list.

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"11.0.x","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
28 November 2018

UID

ibm10742727