Troubleshooting
Problem
User launches Controller client. User receives error.
All users affected. No users can logon.
Symptom
An error occurred while trying to access the server
...Unable to complete login process due to delay in opening server connection
Controller Configuration:
If click on green 'tick' button (to test the database connection) this error appears:
Connection failed
Unable to complete login process due to delay in opening server connection.
Cause
The Controller application server cannot connect to the relevant SQL database.
Example #1
In one real-life customer example, the SQL database server required a reboot.
Example #2
In a different real-life customer example, the Microsoft SQL database server was configured to use Microsoft 'High Availability' (HA) where there were two replicas of the database (hosted on two separate SQL servers). However, the HA was misconfigured.
Environment
Controller database hosted on a Microsoft SQL database server.
Diagnosing The Problem
Example #2
When trying to connect to the SQL server using SQL Management Studio, the following error occurred:
Cannot connect to <servername>
The target database, '<databasename>' is participating in an availability group and is currently not accessible for queries. Either data movement is suspended of the availability replica is not enabled for read access. To allow read-only access to this and other databases in the availability group, enable read access to one of more secondary availablilty replicas in the group. For more information see the ALTER AVAILABILITY GROUP statement in SQL Server Books Online. (Microsoft SQL Server, Error: 976)
Resolving The Problem
Fix the issue with the SQL database server.
Example #1:
It may be necessary to reboot the Microsoft SQL server.
- TIP: After rebooting the SQL server (and waiting for it to be online again), you may get problems with your Cognos BI (or Cognos Analytics) content manager service, caused by the outage (lack of connectivity to its contentstore SQL database)
- Therefore you may need to restart that Windows service (by default called "IBM Cognos").
Example #2:
Ask your I.T. department's SQL server administrator (DBA) to fix the High Availability problem (on the SQL server).
Was this topic helpful?
Document Information
Modified date:
24 April 2019
UID
ibm10741363