Troubleshooting
Problem
You have locked yourself out of the role System Administrator.
Symptom
You are unable to administer the system anymore.
Cause
No user, group, or role that you currently have access to - has access to Manage or the Administration Console anymore.
Diagnosing The Problem
Access to Manage or the Adminstration Console fails.
Resolving The Problem
- Stop the Cognos Analytics Server
- Use database tools to create a physical backup of the Content Store state
- Use database tools to connect to the content store and run ...\cognosinstallation\configuration\schemas\content\<content_store_vendor>\AddSysAdminMember.sql against the Content Store
The folder <content_store_vendor> needs to match your Content Store's database vendor.
After the script ran, the built-in security group Everyone is back in the System Administrator role - at this moment every user is a System Administrator. - Proceed to start the Cognos Analytics Server
- Add any eligible users, groups, and roles to the System Administrator role, remove the Everyone group if necessary
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"Content Manager","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
15 November 2018
UID
ibm10740589