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HTTP 400 Bad Request when running reports using Apache HTTP Server

Troubleshooting


Problem

When accessing Cognos Analytics using an Apache HTTP Server gateway, running certain reports results in "HTTP 400 Bad Request - Your browser sent a request that this server could not understand. Size of a request header field exceeds server limit".

Cause

The size of the header in the request, the number of headers in the request, or the HTTP request line exceeds the allowable size in Apache HTTP Server.

Resolving The Problem

Increase the Apache header and request line size limits by adding the following directives to the httpd.conf file before loading the cognos.conf (or any other Cognos related directives): 

LimitRequestFieldSize
LimitRequestFields
LimitRequestLine

Example:

LimitRequestFieldSize 32768
LimitRequestFields 32768
LimitRequestLine 32768

After adding these directives, ensure that Apache is restarted.

 

For more information on these settings, see Apache's documentation: https://httpd.apache.org/docs/2.4/mod/core.html#limitrequestfields

Related Information

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
05 November 2018

UID

ibm10738697