Troubleshooting
Problem
In the IBM Rational Rhapsody 8.3.1 client with the Rational Rhapsody Model Manager (RMM) / Architecture Management (AM) client installed, you have opened a model stored in RMM, but requirements from a collection are not loading.
Symptom
You have just added an RM collection to your model, or have opened a model where an RM collection was previously added, and the requirements that are part of the collection are listed in the Rhapsody model browser as "Loading" with no further details. Additionally, the Rhapsody client indicates that it has only loaded 1% of the requirements in the collection.
You have Rhapsody 8.3.1 iFix002 installed.
Cause
The Rhapsody 8.3.1 iFix002 installer includes a .bat file which must be run in order for the iFix to successfully update all of the necessary files. If the .bat file is not run, or it is not executed with the necessary permissions, one or more Rhapsody files may not be updated. In this case, one of the Rhapsody Model Manager (RMM) .jar files has not been updated and is still the 'old' version from iFix001 or the 8.3.1 base release.
Diagnosing The Problem
Check the Share/Profiles/RhapsodyModelManager/com.ibm.rational.rhapsody.rmm.client.lib folder and look for the file:
com.ibm.rational.rhapsody.rmm.svg_6.0.600.201808161559.jar
If you have a file with a similar name, but the date section of the filename (201808161559 e.g. 2018 / 08 / 16 15:59) is older, then iFix002 was not installed fully and is the likely cause of this issue in the Rhapsody client.
Resolving The Problem
Close Rhapsody and re-run the Rhapsody 8.3.1 iFix002 installation. It is recommended to launch a command prompt as Administrator, and to execute the setup.bat file from there. Leave the command prompt window open until the batch file has completed.
Product Synonym
Rational Rhapsody
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Document Information
Modified date:
27 May 2022
UID
ibm10738643