IBM Support

Intermittently customized home view does not respect user roles

Troubleshooting


Problem

In a single server Cognos Analytics environment two custom views have been uploaded, View 1 and View 2. Home view for a particular role has been set to View 2.

Intermittently, a user that belongs to this role gets either view when accessing Cognos via dispatcher.

Symptom

Refreshing in Internet Explorer would intermittently change the home view

Cause

Cognos Analytics was installed on a VM. A clone of this VM was delivered to a customer  and than hostname in all URLs was changed to IP address. Group host in Configuration group was left as the hostname of the original VM.

Resolving The Problem

Use FQDN name of the server in all URLs and as the group host in Configuration group

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"11.0.11","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
25 October 2018

UID

ibm10737441