IBM Support

CSV reports fail to run and produce the error DPR-ERR-2072

Troubleshooting


Problem

This document addresses the issue when CSV reports with many rows fail to run returning the error message DPR-ERR-2072. This issue seems to occur with CSV reports with many rows where the Report Execution Mode has been set to 64-bit.

Symptom

Report returns the error message:

DPR-ERR-2072 Unable to load balance a request with absolute affinity, most likely due to a failure to connect to the remote dispatcher

Cause

When a user runs an interactive report, the report server sends a request to the Content Manager, asking it to store the report output in the session cache for the user.

  •  These user session files are stored on the report server's local file system. This is to reduce the processing load on the Content Manager.

Resolving The Problem

Modify the setting "Temporary objects location" from the current ("ServerFileSystem") to the value "Content Store".  This can be done as follows:

  1. Launch the Cognos Analytics portal.
  2. From the Administration console, got to Configuration-->Dispatchers and services
  3. Click the "Set properties-Configuration" option in the top right corner above the dispatchers.

image-20181024162456-3

4.Click "Settings" and change the Catagory to "Tuning"

image-20181024163751-4

5.Change the setting for "Temporary objects location" to "Content store" and click ok.

6.Test.

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"11.0.x","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
25 October 2018

UID

ibm10737267