Question & Answer
Question
How to avoid new alerts consolidating with old (closed) alerts when createException API is invoked with Consolidate="Y"?
Cause
When multiple alerts are existing for an ORDER_NO and ORDER_HEADER_KEY then the newly created alerts (for same order_no) by default will be consolidated to the earlier closed/open alerts. Here if a new (open) alert is consolidated with existing (closed) alert then this new alert will also be considered to be in the closed status. When new open alert consolidates to existing open alert the final status considered is open and it will wait for a resolution or an event to be executed so that it can eventually close.
Answer
To avoid new alert consolidating with close alert modify the createException API input by adding ActiveFlag="Y" under consolidation template.
The createException API input for reference,
<Inbox Consolidate="Y" ActiveFlag="Y" .....
<ConsolidationTemplate>
<Inbox ActiveFlag="Y" ExceptionType="<exception_type>" OrderHeaderKey="<order_header_key>"/>
</ConsolidationTemplate>
Now each time the exception is raised for same 'ORDER_NO' a new alert will raised which does not consolidate to the older alerts.
Product Synonym
Sterling OMS
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Document Information
Modified date:
14 November 2018
UID
ibm10734855