IBM Support

On IBM Call Center for Commerce, user exit "BeforeChangeOrderUE" is not invoked if order has more than 10 lines

Question & Answer


Question

When there are more than 10 order lines for an order, while moving from "fulfillment summary" screen to "Add payment" screen, what is the reason for the user exit "BeforeChangeOrderUE" not being invoked ?

Cause

The functionality is working as per application design. For large orders, we do not stamp FTC dates on the order lines, as described here:
https://www.ibm.com/support/knowledgecenter/en/SSGTJF/com.ibm.help.wcc.impl.doc/developerconcepts/c_wcc_viewfulfillmentsummary.html

Answer

Stamping the FTC date calls changeOrder, and invokes BeforeChangeOrderUE as a result. The default value for a large order is 10 lines.

This can be changed in Sterling Business Center application (SBC) by navigating to System Setup -> Call Center For Commerce Administration -> Fulfillment Options and changing "Show Availability Information In Fulfillment Summary If Number Of Orderlines Is Less Than:".

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Component":"","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"9.5,18.1,18.2","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
30 September 2018

UID

ibm10733385