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How can we increase the token's active period in IBM Sterling Order management?

Question & Answer


Question

How can we increase the token's active period  in IBM Sterling Order management?

Cause

You want to know for how many minutes will a token be active or usable before it becomes invalid.

Answer

You can invoke the login API to get a user token and use the token to call any webservices.
The api.security.token.timeout property controls how long the token can remain active. The default token time out value is 1800000 ms. And there is no max limit for api.security.token.timeout property i.e it can be increased to any value.

To increase the token's active period, set the value for yfs.api.security.token.timeout property in customer_overrides.properties file and restart the Server.

For example- If the property yfs.api.security.token.timeout is set to 30secs, invocation of any API (with the same token) will result in "Cannot invoke API because user is not authenticated" error after 30secs, as the user-token got expired post 30seconds.

Related Information

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
28 September 2018

UID

ibm10733363