Troubleshooting
Problem
A user creates a large report and saves it as a PDF, where the output is in the range of 200+MB. When downloading the saved output from the View Versions pane, when clicking on the PDF the Adobe Reader plugin loads, but the loading bar inside the plugin shows that it is being downloaded very slowly (several kB per second). While this is happening, the iexplore.exe browser process on the client PC is using CPU and becomes unresponsive. The problem may be exacerbated if the PDF Compression level has been increased in the properties of the report service / batch report service.
The problem only occurs using Adobe Reader in Internet Explorer. The built in PDF viewers in Firefox and Chrome do not have the same issue.
Cause
The issue is caused by Adobe Settings which cause the PDF to be downloaded in small pieces.
Resolving The Problem
Open Adobe Reader on the client PC, then click Edit > Preferences > Internet. Uncheck the following settings:
Allow fast web view
Allow speculative downloading in the background
Click OK, then close Adobe Reader. After restarting Internet Explorer, the PDF download should be much quicker.
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Document Information
Modified date:
26 September 2018
UID
ibm10733134