IBM Support

Users In Active Directory Group don't appear In a Cognos Role or Group Under "My Preferences"

Troubleshooting


Problem

When an AD group containing multiple users is added to a Cognos role, the group appears as if its in the role. However a user in the group will not see themselves added to the role under "My Groups and Roles". (This isn't counting the default groups of everyone and all authenticated users).

Symptom

If in Cognos Configuration, if "Restrict access to members of the built-in namespace" is set to true, the user who is in a Cognos Role may still not be allowed access into Cognos.

Cause

The Cognos service account does not have the sufficient rights to gather the information of users and what groups they belong to.

Resolving The Problem

1 - If bind user settings are specified, you only need to make sure this user has the required read permissions to view members of the AD. This is because Cognos gives all users of the AD the rights of that user to all the users.

2- If bind user settings are not specified, make sure that the user accessing Cognos has the required read permissions.

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Document Information

Modified date:
01 October 2018

UID

ibm10732892